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Part 1 - Introduction of Application

The IDPM Compact is an application that can be used on a Windows platform that provides a 
function to add and save meta information to hide sensitive privacy information when viewing an 
image without modifying or changing the original clip file (a video file with a built-in player)

Recommended Specifications and Minimum Specifications

Recommended Specifications Minimum Specifications

OS Microsoft® Windows® 10 x86 (32/64 Bit)

(Home, Professional)

Microsoft®Windows® 7 x86 (32/64 Bit)

(Home Premium, Professional, Ultimate)

CPU Intel Core™ i7-3770 3.40 GHz or faster Intel CoreTM i3-3220 3.30GHz

RAM 8 GB or more 4 GB

VGA NVIDIA GTX750 or AMD Radeon™ R7 265 or higher 

(1920x1080, 32bpp)

NVIDIA GT730 or AMD Radeon™ HD HD7730 

(1280x1024, 32bpp) 

HDD 4 GB or more free space 1 GB
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Part 1 - Introduction of Application

Limitations of Application

Based on the current version

●● Does not support a server operating system.

●● Can be used on a system that supports DirectX 9.0c or later.

●● Does not provide a Fish-Eye Dewarp function.

-- Supports a privacy masking for Fish-Eye Original Video.

●● Limitations on the original clip

-- Supports only a clip with Version 4.0.0 or later clip player.

●● Limitations on the clip reproduction

-- Partial reproduction function will be added later on.

-- A clip file has 3GB limitations. The clip file is provided in a self-executable form. On Windows OS, a 4GB size file is not 

recognized as a normal executable file. It means that it is impossible to get it enabled. For this reason, a 3GB standard 

has been set for the size of a clip file, excluding the metadata that will be included to accommodate the increased size 

and the added size of the metadata.

●● Limitations on CPU functions

-- It operates only on a system that uses a CPU supporting SSE2 or higher to perform operations such as object tracking.
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Installing IDPM Compact

Run Setup.msi to install IDPM Compact. You can install a drive root other than a patch such as C:\ or 
D:\.

Part 2 - Installation Instructions
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Part 3 - Application Interface

File Menu

If you click the File in the menu at the top of the 
program, the related context will pop up.

●● Open Menu : This is a menu for opening clips.

●● Save Menu : This is a menu for saving new clips with 

privacy information.

●● Close Menu : This is a menu for closing clips.

●● End Menu : This is a menu for ending the program.

Object Menu

If you click the Object in the menu at the top of 
the program, the related context will pop up.

●● Add Object Menu : This is a menu for adding objects

●● Delete Object Menu : This is a menu for removing 

selected objects.

●● Edit Object Menu : This is a menu for editing selected 

objects.

●● Select Object Menu : This is a menu for selecting 

objects.

●● Release Object Selection Menu: This is a menu for 

finding and releasing selected objects.
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Part 3 - Application Interface

Mask Menu

If you click the Mask in the menu at the top of 
the program, the related context will pop up.

●● Mask Interpolation Menu : This is a menu for inserting 

a mask that interpolates the frames between the mask 

and the mask.

●● Mask Delete Menu : This is a menu for deleting a series 

of consecutive masks.

Help Menu

If you click the Help in the menu at the top of 
the program, the related context will pop up.

●● About : A window pops up where you can see the 

program version information and open the source 

license status. You can see the open source status of the 

program if you click on the location of the open source 

license text display in that window. The window closes 

again if you click on the window.

Channel Combo Box

Depending on the channels included in the clip, 
the combo box displays the channels that the 
user can see and mask. When selecting a channel 
in the combo box, the first frame of the channel 
is opened. If the object and masking data are 
already included, the corresponding information 
is updated in the object view.
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Part 3 - Application Interface

Collection of Playback Control

●● Playback/Track Playback Toggle Button (Normal/

Tracking Play Toggle Button) : Control for toggling 

between normal playback mode and tracking playback 

mode.

●● First Frame Button (First Button) : Control for moving to 

the first frame.

●● Previous Frame Button (Previous Button) : Control for 

moving to the previous frame.

●● Playback/Pause Toggle Button (Play/Pause Toggle 

Button) : Control for toggling between playback and 

pause.
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Part 3 - Application Interface

●●  Next Frame Button (Next Button) : Control for moving 

to the next frame.

●● Last Frame Button (Last Button) : Control for moving to 

the last frame.

●● Current Frame Time Information Control (Current Time 

Control) : Control for displaying the current frame time 

information.

●● Keyframe Slider: Slider control for moving between 

keyframes.

●● Time Bar: Control for moving to any frame among 

all frames. During playback, the time position of the 

currently playing frame is displayed.
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Part 3 - Application Interface

Collection of Object and Mask Controls

●● Add Object Button: Control for adding objects

●● Delete Object Button: Control for deleting objects.

●● Edit Object Button: Control for editing objects.

●● Interpolate-Masks Button: Control for interpolation 

between masks.
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Part 3 - Application Interface

●● Delete Mask Button: Control for deleting masks 

between masks.

●● Mosaic Toggle Button: Control for toggling the mask 

area between normal display and mosaic display. 

●● Object View: When adding an object, a widget is 
displayed on the left side of the view to show the color 
of the object, the name of the object, and the selection 
status for working with the object. Then, a mask timeline 
is drawn on the right side, depending on the existence 
or non-existence of the mask that is masked by selecting 
the object. The timeline is the same as the time point 
corresponding to the horizontal axis position of the time 

bar.
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Part 4 - Application Function Specifications

Open and Close Clips

●● Open: This is a function to open a clip. If the clip is 

password-protected, the password input window will 

pop up. If you enter the password at this time, the clip 

will open.

●● Close: This is a function to close a clip. The clip you are 

working on will be closed.

●● Playback: This is a function to play a clip. Playback 

functions are available through the collection of 

playback controls. 

-- Play : Press the Play button. When playing, the frame 
will be played back at the time interval between each 
frame. In the case of keyframe playback, the time 
interval may differ from the actual frame time.

-- Pause : Press the Play button to toggle the Play button 

from the Play state to the Pause button. When this 
button is pressed, the Play state changes to the Pause 
state, and the frame playback stops. 

-- Move Frames : There are functions such as the 
movement of the First Frame, movement of the 
Last Frame, movement of the Previous Frame, and 
movement of the Next Frame. 

-- Movement of the First Frame is possible by 
pressing the First Frame button. It is activated so 
that you can press in the Stop mode.

-- Movement of the Last Frame is possible by pressing 
the Last Frame button. It is activated so that you 
can press in the Stop mode.

-- Movement of the Previous Frame is possible by 
pressing the Previous Frame button. It is activated 
so that you can press in the Stop mode.

-- Movement of the Next Frame is possible by 
pressing the Last Frame button. It is activated so 
that you can press in the Stop mode. 

●● Save: Clips with privacy information added can be saved 

as new self-executing clips. You can save it by selecting 

the Save menu in the File menu.
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Part 4 - Application Function Specifications

Add, Edit, Delete, and Select Objects

It is an object to draw the mask. The object includes the 
information about how to mask the object. The current 
masking method is provided to select the color of the 
rectangular area and its four sides.  An object can be 

named by its string.

At present, the number of objects that can be added per 
channel is 64.

Addition

An object is created by specifying the color of the mask 
to mask the objects and the name of the object. Select 
Object>Add Object from the top menu of the window, 
and the Add Object window will pop up. 

Select a color in this window and press the Next button. 
The window switches to the window to input the name 
of the object. In this window, enter the object name and 

click OK. 

Note that you must use an object name that does not 
already exist. 

You can also use this function by pressing the Add Object 
button in the control bar just below the screen. When an 
object is added, a control will be added to the object view 

that represents the object.

Edit

Edit the selected object. You can change the color and 
name of the object. If you select Object>Edit Object, the 

Edit Object window will pop up. 

You can edit the objects the same way you add colors or 

names. 

You can also use this function by pressing the Edit Object 

button in the control bar just below the screen.

Delete

Delete the selected object. When you delete an object, 
the masks drawn for the object will also be deleted. If you 
select Object>Delete Object, a query window asking you 

if you would delete the object is displayed again

Select Yes in the window to delete the object.
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Part 4 - Application Function Specifications

Selection

Selects an object. You can select an object by selecting 
Object>Select Object menu, or by clicking on the space 
on the right side of the object control in the object view. 
When the object selection menu is clicked, the object 
selection window will be displayed. At this time, you can 
select the object by selecting the Radio button with the 

object name. 

A red check will be displayed on the right side of the 

object view for the selected object.

Draw Masks and Mask Interpolation, Delete All Masks

DrawMasks

You can draw a mask on the screen while playback is 

stopped and an object is selected. 
Or you can reduce or enlarge the area by dragging the 
mouse to one of the four vertex areas of one of the masks 
displayed on the screen, even if an object is not selected.  
Place the mouse in the center of the unselected mask area 
and drag it with the left mouse button. You can move the 

mask from the screen.
If you press and hold the left mouse button on the center 
of the mask and click the right button, you can delete the 

mask from the frame.

Mask Interpolation

You can insert the mask with linear interpolation between 
two spaced frames.

For example, to use the interpolation between Frame 1 
and Frame 100, you have to draw a mask in Frame 1 and 
Frame 100. If you press the interpolation button or select 
Mask>Interpolation, the mask interpolation window 
will be displayed.  

Enter the number of the first frame and the number of 
the last frame, and press the OK button. Based on the 
position and the size of the mask in the first frame and the 
mask in the last frame, the position and size are increased 
or decreased linearly, and the masks are drawn on every 
frame in between.

Delete All Mask

Delete all masks within the specified sector, specifying a 
sector of the mask drawn for the selected object. Available 
via Mask>Delete. Or press the Delete Mask button. 

When the Delete Mask window is displayed, specify the 
frame sector as a number and click OK.
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Part 4 - Application Function Specifications

Object Tracking

You can toggle between the normal playback mode and 
the tracking playback mode via the tracking button. This 
toggle is enabled in the Pause state. The object is present 
and the object to be tracked in the frame at the time of 
playback must have a mask drawn on it. And the object 

must be checked as the object to be tracked. 

To select an object as the object to be tracked, click on 
the right space of the object control in the object view.

The selected mask is also included in the tracking target, 
and at present it supports up to five objects to be tracked. 
Track playback is played more slowly than normal 
playback. When these conditions are met, press the Play 

button to start track playback.

●● The selected object is displayed in red on the right side 

of the widget in the object view.

●● The object to be tracked is displayed in black on the right 

side of the widget in the object view.

There is no guarantee about the probability of tracking. 

Tracking is likely to fail in the following cases:

-- When objects to be tracked cross and overlap each 
other.

-- When objects to be tracked move fast
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An example of use sequence for adding simple privacy information

Part 5 - User Usage Scenario

1	 Open the clip file.

2	 Create an object.

3	 Move to the desired frame position.

4	 Draw a mask on the screen, using the object.

5	 Toggle the Tracking Play Mode and start playback.

6	 In the middle of tracking after stopping the playback, 
move to the desired frame to compensate the mask 
and adjust the mask.

7	 Save the clip.

8	 Open the saved clip and check the addition of privacy 
information. Press the mosaic toggle button to check 
the mosaic state.

V1.0
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